jianfen's blog

Information is beautiful

ospf 特殊区域的实质是为了减少区域内路由表条目的数量


stub area 区域

  • 规则:
    1.当stub area中有多个ABR,会同时下放默认路由这时要通过cost值来进行选路或者负载均衡
    2.一旦区域被标示为stub area那么stub area内所有路由器均要配置stub标示(Hello包建邻居要求)
    3.在stub area中不能存在ASBR
    4.stub area不能是area 0 (骨干区域)
    5.作为stub area无法再外挂其他区域(如:虚链路技术)

命令:

在区域内所有路由器:

  router ospf 110
    area 1 stub

    area 1 default-cost 10 (手动设置下放默认路由的cost用于选路默认为1) 立刻生效

作用:过滤4/5类LSA(外部路由)

主动下放默认路由: [O IA]下放3类默认路由 seed cost = 1(初始cost值)


totally stubby Area (完全末节区域)

在末节区域基础之上

  • 规则:
    1.Cisco私有区域
    2.stub area的规则适用于totally stub area
    3.只需比stub area在ABR上area 1 stub no-summary

命令:

在stub区域的ABR路由器:

router ospf 110
    area 1 stub no-summary
        area 1 default-cost 10 (手动设置下放默认路由的cost用于选路默认为1) 立刻生效

作用:过滤3/4/5类LSA(域间和域外路由)

主动下放默认路由: [O IA]下放3类默认路由 seed cost = 1(初始cost值)


Not-So-stubby Areas NSSA区域 '不那么末节的区域'

  • 规则:
    1.可以存在ASBR
    2.引入外部路由但又要过滤从域间传来的5类LSA
    3.产生7类LSA(只在NSSA区域传播)
    - link ID
    路由
    - ADV router
    路由产生者的RID

命令:

在区域内所有路由器:

  • router ospf 110
    area 2 nssa

作用:过滤4/5类LSA 产生7类LSA(在区域再引入外部又不能存在5类所以为7类)到其他区域会以7类转5类LSA形式传播

手动下放默认路由: 下放一条ON2 7类LSA默认路由
在NSSA区域的ABR的路由进程中 area 2 nssa default-information-originate (seed cost = 1 O
N2 不累加cost)


totally stubby Not-So-stubby Areas '完全的NSSA区域'

在NSSA区域基础之上

命令:

在NSSA区域内ABR路由器:

  • router ospf 110
    area 2 nssa no-summary

作用:过滤3/4/5类LSA 产生7类LSA(在区域再引入外部又不能存在5类所以为7类)到其他区域会以7类转5类LSA形式传播

主动下放默认路由: [O IA]下放3类默认路由 seed cost = 1(初始cost值)


NSSA扩展:

  • 当NSSA区域的ABR 重分布外部路由:
    1.普通区域接受到的是正常外部5类LSA路由E2
    2.NSSA区域接受到的是7类LSA路由N2

在NSSA区域的ABR路由进程 优选做法
area 2 nssa no-redistrubution no-summary 过滤nssa中的N2路由 因为NSSA区域已经存在默认路由


不规则区域:
1.远离area 0
2.分隔的area 0 (多area 0 常用于割接)

解决不规则区域:
1.远离area 0

1)多进程的双向重分布
        在ABR上建立2个进程分别重分布OSPF不同进程
        同一路由器:
        router ospf 110
            network 13.1.1.0 0.0.0.255 area 2
            redistribute ospf 100 subnets
        router ospf 100
            network 35.1.1.0 0.0.0.255 area 3
            redistribute ospf 110 subnets
    
    2)Tunnel隧道
        在area 0和area 3最近的路由器上做隧道
        int tunnel 1
            tunnel source 13.1.1.1
            tunnel destination 13.1.1.3
            ip add 172.16.1.1 255.255.255.0 自建ip地址

        
        int tunnel 1
            tunnel source 13.1.1.3
            tunnel destination 13.1.1.1
            ip add 172.16.1.2 255.255.255.0 自建ip地址

        靠近area 0的路由器 把tunnel宣告进area 0
        router ospf 110
            network 172.16.1.0 0.0.0.255 area 0

        靠近area 3的路由器 把tunnel宣告进area 0
        router ospf 110
            network 172.16.1.0 0.0.0.255 area 0

    3)Defining Virtunal Links 虚链路
        通过1类LSA知道RID再找到直连路由信息 建立虚链路
        area 2 virtual-link 3.3.3.3 对方RID
        area 2 virtual-link 1.1.1.1

        show ip ospf virtual-links
            adjacency state FULL 状态成功

OSPF authentication Types ospf认证方式

  • 认证分2个步骤:
    1.启动秘钥
    2.启动认证
  • 认证强度:
    1.simple
    2.md5

认证应用方式:

1.link authentication 链路认证
    在链路两端的接口配置:
    1)int s0/0
        ip ospf authentication-key cisco 启动明文秘钥
        ip ospf authentication 启动明文认证
    
    2)int s0/0
         ip ospf message-digest-key 1 md5 cisco 启动密文秘钥
     ip ospf authentication message-digest 启动密文认证

2.area authentication 区域认证
    在接口下启动明文秘钥
    1)int s0/0
           ip ospf authentication-key cisco
    在路由进程中启动区域认证
    router ospf 110
        area 1 authentication

    在接口下启动密文秘钥
    1)int s0/0
           ip ospf message-digest-key 1 md5 cisco
    在路由进程中启动密文区域认证
    router ospf 110
        area 1 authentication message-digest

3.virtual link authentication 虚链路认证
    明文认证在路由进程中
        area 2 virtual-link 3.3.3.3 authentication-key cisco
        area 2 virtual-link 3.3.3.3 authentication
    
    密文认证在路由进程中
        area 2 virtual-link 3.3.3.3 message-digest-key 1 md5 cisco
        area 2 virtual-link 3.3.3.3 authentication message-digest

PS:当存在虚链路的环境要求做area 0认证需要在tunnel接口下也开启明文/密文配置
在虚链路对端路由器在路由进程中开启认证area 0 authentication
因为tunnel将R3接到了area 0 上

请输入图片描述

其他知识点

等价负载均衡
默认:maxumum-paths 4
router ospf 110
maxumun-paths 6 最大

被动接口 (常用于loopback口)
不收发OSPF报文不代表其他路由器收不到路由被动接口只是将network命令的第一条发送hello包过滤

  • network 命令的作用:
    1.发送hello包
    2.通告路由

router ospf 110
passive-interface loopback 0


添加新评论 »

在这里输入你的评论...

勿忘初心,方得始终.